Subject: (urth) What to read along with Latro

From: Dan Rabin <wolfe-lists at danrabin.com>
Date: Tue, 21 Jan 2003 07:55:04 +0000

I've read the Latro books twice.  The second time was after I read 
Herodotus.  That helped a lot with the history and geography, besides 
being a lot of fun in itself.

   -- Dan Rabin

--

---

From: Josh Geller <dclxvi at dclxvi.best.vwh.net>
Date: Tue, 21 Jan 2003 08:03:38 +0000

> being a lot of fun in itself.

Herodotos is great. Herodotos and Bernal Diaz del Castillo are perennially
tied for being my favorite book. I reread them both at least once a year.

.

--