Subject: (urth) Hierodule

From: p.duggan at verizon.net <p.duggan at verizon.net>
Date: Thu, 25 May 2006 17:26:12 +0000

Hierodulia is also the scientific name for a Praying Mantis, and the hierodules have insect-like faces behind their masks.

Paul

---

From: Jeff Wilson <jwilson at io.com>
Date: Fri, 26 May 2006 04:51:05 +0000

> Hierodulia is also the scientific name for a Praying Mantis, and the hierodules have insect-like faces behind their masks.

Or rather, insect-like masks behind their face-like masks.

-- 
Jeff Wilson - jwilson at io.com
< http://www.io.com/~jwilson >

---

From: don doggett <kingwukong at yahoo.com>
Date: Fri, 26 May 2006 04:59:56 +0000

> Or rather, insect-like masks behind their face-like

My understanding is that they have human face masks
covering monstrous cthuluesque masks and the insectoid
faces are their true ones. Mantises have strangely
beautiful faces if you've ever seen one in person.

Don

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Jeff Wilson <jwilson at io.com>
Date: Sat, 27 May 2006 04:34:19 +0000

> beautiful faces if you've ever seen one in person.

*shiver* Are you sure you're not Borski wearing a doggett-like mask?