Subject: (urth) battlestarcrosser

From: Ranjit Bhatnagar <ranjit at moonmilk.com>
Date: Wed, 11 Jun 2008 18:28:01 +0000

Is anyone else here watching the current remake of Battlestar
Galactica?  I was amusing myself by thinking of parallels between the
cylons and the imhumi.

-r

---

From: Stuart Hamm <hammstu at sbcglobal.net>
Date: Wed, 11 Jun 2008 18:55:39 +0000

I was afraid to bring up the subject...and there are even more Wolfe-ish
nods I think...nontheless I am enjoying it immensely 
It took me a while...I just couldn't get past the image of Lorne Greene in a
disco-space=suit.
Best show on...only one I watch...religiously.

-----Original Message-----
From: urth-bounces at lists.urth.net [mailto:urth-bounces at lists.urth.net] On
Behalf Of Ranjit Bhatnagar
Sent: Wednesday, June 11, 2008 11:28 AM
To: The Urth Mailing List
Subject: (urth) battlestarcrosser

Is anyone else here watching the current remake of Battlestar Galactica?  I
was amusing myself by thinking of parallels between the cylons and the
imhumi.

-r
_______________________________________________
Urth Mailing List
To post, write urth at urth.net
Subscription/information: http://www.urth.net

---

From: Bryan Alexander <bryan.alexander at gmail.com>
Date: Thu, 12 Jun 2008 05:48:47 +0000

My whole family has been watching it, and are very caught up.  Impressive
work on many levels.
And I admit to adding a gratuitous "Viva Adama!" slide to my presentations
this year.

On Wed, Jun 11, 2008 at 2:28 PM, Ranjit Bhatnagar <ranjit at moonmilk.com>

-- 
Bryan Alexander
http://infocult.typepad.com/
http://twitter.com/BryanAlexander
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20080612/a6489a07/attachment.htm>