Subject: (urth) New Sun vocabulary watch

From: Tim Walters <walters at doubtfulpalace.com>
Date: Wed, 01 Oct 2008 06:54:42 +0000

Enormous folk band Bellowhead's new album is called MATACHIN (after the 
sword dance, but hey).

Fortunately, Bellowhead rule:

http://www.youtube.com/watch?v=yBE5ovRJQn8
http://www.youtube.com/watch?v=L5t6S7ujK0w

-- 

Tim Walters | The Doubtful Palace | http://doubtfulpalace.com

---

From: Allan Anderson <rubel at goosemoon.org>
Date: Wed, 01 Oct 2008 18:02:18 +0000

These folks are tremendous fun! Thanks for the links.

Tim Walters wrote:
> Enormous folk band Bellowhead's new album is called MATACHIN (after 
> the sword dance, but hey).
>

---

From: Paul B <pb.stuff at gmail.com>
Date: Wed, 01 Oct 2008 19:17:22 +0000

ANATHEM vocabulary watch:
http://xkcd.com/483/

Wolfe, clever man that he is, is unencumbered by this restriction.

Paul
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20081001/22fa4ea7/attachment.htm>

---

From: Matthew Groves <matthewalangroves at gmail.com>
Date: Thu, 02 Oct 2008 16:17:04 +0000

That is brillarious.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20081002/12cd937e/attachment.htm>