Subject: (urth) re silk is concr?te

From: Son of Witz <sonofwitz at butcherbaker.org>
Date: Thu, 06 Nov 2008 20:42:12 +0000

>> Hey Tim,
>> I'm really digging the Musique Concr?te you've got posted there.
>> Evocative stuff.  I could listen to a lot more of that. Lemuria was very
>> cool.
>
>Thanks!
>
>> I do artwork for a band that has incorporated a bit of musique concr?te in
>> their albums, called Secret Chiefs 3.
>
>Is that Mike Patton's thing, or am I misremembering? The name is familiar,
>anyway. <google google> Looks like I had the wrong Mr. Bungle guy.

sort of started as Bungle without Patton, but has long since eclipsed anything Patton has done in terms quality, but definitely not notoriety. Not too many people know of SC3.  It's Trey Spruance's baby. the other bungle guys are not active in SC3 much anymore.

>> It's not their dominant mode, but
>> some appears on the album I illustrated called Book of Horizons.
>
>Are the illustrations on-line anywhere?

all of them are on my site.
http://www.butcherbaker.org/
it's flash based, takes a bit to load.
once you see the menu, go to Package Art > Secret Chiefs 3:Book of Horizons
it's sorta weird. There is a Borges thing going on in SC3 in that it is made up of 7 imaginary bands, and each genre has been alchemically sublimated into individual identities. I had to do logos and illustrations for each band.  ALL according to Trey's art direction.  (I didn't do the Holy Vehm death metal logo though)

it may be worth a look at SC3:Path of Most Resistance cover. I did it long before Obama was a candidate, and we were going for a Senator as Antichrist thing. So fans of the Obama is Antichrist might like this, cause it actually looks like Obama in silhouette.  ha!

'nuff pimping my shit.
*sorry*

>Maybe the musicians on this list should get together and do a Gene
>Wolfe-inspired album....

that'd be cool as hell
This week, my Monomachy illustration will be printed on a band's tee shirt, and I'm working an New Sun inspired Amphisbaena into another project.

~witz

---

From: Tim Walters <walters at doubtfulpalace.com>
Date: Thu, 06 Nov 2008 22:38:52 +0000

> http://www.butcherbaker.org/

Gorgeous stuff!

And hey, Sleepytime! I love those guys.

-- 
Tim Walters | http://doubtfulpalace.com

---

From: Son of Witz <sonofwitz at butcherbaker.org>
Date: Thu, 06 Nov 2008 22:51:31 +0000

>And hey, Sleepytime! I love those guys.

thanks.
yeah, Sleepytime Gorilla Museum is one of my faves.
I've done some posters and ads, but no album covers.
A great Live band when they're not over indulging in their performance art aspect.
~witz

---

From: Allan Anderson <rubel at goosemoon.org>
Date: Thu, 06 Nov 2008 23:42:33 +0000

> A great Live band when they're not over indulging in their performance art aspect.

I love those bands, too. Excellent to see your art!

---

From: Son of Witz <sonofwitz at butcherbaker.org>
Date: Fri, 07 Nov 2008 00:19:34 +0000

>I love those bands, too. Excellent to see your art!

Thanks.
regarding those bands, I'm very lucky to work with my some of my favorites.
It all started when I didn't like the teeshirts Estradasphere had at shows, so I drew one I liked better.  I told my wife, "wouldn't that be great if they wanted me to do their album cover?  Then maybe I could ask them to play our wedding as payment."  They never used that shirt design, but I've done 3 covers, several shirts, and they played our wedding. So I'm a strong believer in just putting yourself out there.

(I've started illustrating Book of the New Sun, though no one is asking me to.  Might as well shoot for Lune.)

~witz