Subject: (urth) ot: three seconds of fame

From: don doggett <kingwukong at yahoo.com>
Date: Sun, 23 Aug 2009 00:41:05 +0000

Hey, it's been pretty slow here so I thought I'd toss this out. I recently wrote a blog razzing Neil Gaiman for that leather jacket he seems to wear on all his author photos and he posted a response. In my defense, I wasn't sniping for Mr. Gaiman; I just write what I feel like writing. But someone tweeted, twitted, tw at tted, or whatever and it got back to him. I've always wanted to tell him I hated those photos (and all author photos, really) so it ended up being quite satisfying in a bad monkey kind of way. It's the post entitled I Swear to God I Would Do It.

peace, my Urthly homies
Don

Doggerel
www.don-doggett.blogspot.com

---

From: Allan Anderson <rubel at goosemoon.org>
Date: Sun, 23 Aug 2009 06:15:01 +0000

That's fun, Don.
My favorite Neil representation has to be Eddie Campbell's, in _King
Bacchus_, where Neil passes out due to an excess of disturbing occultism and
thick smoke from Alan Moore.

That, and later on when he shows up again in the same comic, wearing the
jacket AND the sunglasses--"Hey, you standing sideways!" they call out to
him.

On Sat, Aug 22, 2009 at 5:41 PM, don doggett <kingwukong at yahoo.com> wrote:

> Hey, it's been pretty slow here so I thought I'd toss this out. I recently
> wrote a blog razzing Neil Gaiman for that leather jacket he seems to wear on
> all his author photos and he posted a response. In my defense, I wasn't
> sniping for Mr. Gaiman; I just write what I feel like writing. But someone
> tweeted, twitted, tw at tted, or whatever and it got back to him. I've always
> wanted to tell him I hated those photos (and all author photos, really) so
> it ended up being quite satisfying in a bad monkey kind of way. It's the
> post entitled I Swear to God I Would Do It.
>
> peace, my Urthly homies
> Don
>
> Doggerel
> _______________________________________________
> Urth Mailing List
> To post, write urth at urth.net
> Subscription/information: http://www.urth.net
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20090822/8c1500bc/attachment.htm>

---

From: brunians at brunians.org <brunians at brunians.org>
Date: Sun, 23 Aug 2009 11:49:42 +0000

> Bacchus_, where Neil passes out due to an excess of disturbing occultism
> and thick smoke from Alan Moore.

Alan Moore is a wack-job.

A brilliant wack-job, but still a wack-job.

.