Subject: (urth) Car Sinister

From: Jeff Wilson <jwilson at io.com>
Date: Wed, 02 Jun 2010 10:27:57 +0000

A recently serviced vehicle for your viewing "pleasure".

http://thereifixedit.files.wordpress.com/2010/05/129187855173854450.jpg

-- 
Jeff Wilson - jwilson at io.com
IEEE Student Chapter Blog at
< http://ieeetamut.org >

---

From: brunians at brunians.org <brunians at brunians.org>
Date: Wed, 02 Jun 2010 11:15:40 +0000

Someone's been thinking.

.

> _______________________________________________
> Urth Mailing List
> To post, write urth at urth.net
> Subscription/information: http://www.urth.net
>