Subject: (urth) Shadow of the Torturer: Doom Metal Band

From: Son of Witz <sonofwitz at butcherbaker.org>
Date: Fri, 10 Jun 2011 16:19:42 +0000

I just stumbled onto this as I was looking for that music video of the
Shadow of the Torturer "Filk" song. I can't remember the singer's name...

Not sure if this has been shared here, but there is a Seattle WA Doom
Metal band called Shadow of the Torturer.

http://www.myspace.com/shadowofthetorturer

I'm halfway through Cities of the Damned.  I love this kinda shit.
File under: Acquired Taste
Sub-Category: If you don't get it by now, you never will...

No novel ideas on display, but it's pretty satisfying if you like this
sort of depressive anti social stuff from the lowest sub-genre of heavy
metal. Sounds like a cross between something like Burning Witch and Om.
Not as torturous as Burning Witch though, which is a plus in my book.
Spare me from those excruciations.

...I have no idea what the lyrical content is. Your guess is as good as mine.

~witzenheimer

---

From: Stuart Hamm <hammstu at sbcglobal.net>
Date: Sat, 11 Jun 2011 17:07:39 +0000

Gonna go down cellar and lie dow....!

???????? ? ? 

? ?? 

--- On Fri, 6/10/11, Son of Witz <sonofwitz at butcherbaker.org> wrote:

From: Son of Witz <sonofwitz at butcherbaker.org>
Subject: (urth) Shadow of the Torturer: Doom Metal Band
To: urth at lists.urth.net
Date: Friday, June 10, 2011, 9:19 AM

~witzenheimer

_______________________________________________
Urth Mailing List
To post, write urth at urth.net
Subscription/information: http://www.urth.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20110611/8fe246c7/attachment.htm>

---

From: Daniel Petersen <danielottojackpetersen at gmail.com>
Date: Mon, 13 Jun 2011 22:55:24 +0000

haha! yep, I like it.  But the lyrics are atrocious:
http://www.reverbnation.comww.reverbnation.com/artist/song_details/8440373

oh well.  cheers for sharing.

-DOJP

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20110613/b636b686/attachment.htm>