Subject: (urth) (no subject)

From: Lee Berman <severiansola at hotmail.com>
Date: Thu, 17 Nov 2011 21:22:07 +0000

>James Wynn: Also, there is the whole (quite intentional) Osiris motif in which Isis 
>(Kypris) has to run around gathering parts of the god after he has been murdered.
 
>Marc Aramini: I agree that the mapping of some myths are to be expected and found, 
>my problem with bringing in a bunch of different mythos is that Wolfe couldn't have 
>alluded to them all intentionally and still made a good story 
 
>David Stockhoff: I dunno, Marc. Osiris's murder story is a very specific, concrete 
>narrative which is plainly retold here up to a point.
 
I concur. Moreover there is some evidence that Wolfe is intentionally shifting his
allusion from Greco-Roman myth allusion of Urth to the sea neigbor/rival Egyptian mythology
for the Whorl. The two(as far as I know) Greek and Egyptian mythological characters which 
share a name are Typhon and Sphinx. And Wolfe has included both in this story.

---

From: David Stockhoff <dstockhoff at verizon.net>
Date: Thu, 17 Nov 2011 21:29:30 +0000

> share a name are Typhon and Sphinx. And Wolfe has included both in this story. 		 	   		

Good observation. And Isis.

---

From: Larry Miller <decanus1284 at gmail.com>
Date: Thu, 17 Nov 2011 22:29:54 +0000

I agree  with both of you.  I think its best when reading the sun
books to aply  only one  or two layers.  On my last reading of New Sun
I simply tried looking for references to Theseus and Christ for
example.

On 11/17/11, David Stockhoff <dstockhoff at verizon.net> wrote:
> _______________________________________________
> Urth Mailing List
> To post, write urth at urth.net
> Subscription/information: http://www.urth.net
>