Subject: (urth) Peace, Blaine's senile memories, and the egg

From: Marc Aramini <marcaramini at yahoo.com>
Date: Sat, 21 Dec 2013 16:09:40 +0000

One of the biggest problems with making the story of the dog boy fit with the majority of Peace is of course the age of the child Doris, the carnival stepdaughter?- she is old enough to be considering marriage, and it does not seem plausible that she could be Sherry Gold's unless there is some kind of time displacement (Sherry is 16 when Den is 45 or so, and in about 15-20 years, Den will have his stroke at about 60 the day after Sherry dies - events related?)? However, it appears the story of Doris would not allow her to be old enough to be Sherry's, if Den is visited by the dog boy at the age of 50 when he is retiring. If they had a child, the child would be about 5 years old at the time of the carnival letter.

HOWEVER, there is a time slippage of years in Blaine's memories, when he identifies Weer as "Jimmy" (James McAfee, who got the egg from Olivia?) and claims that "Jimmy" couldn't have been more than 14 or 15 years old when Roscoe McAfee was given the egg at Christmas by Vi before prohibition. Den was, I think younger than that at about age 9 after Bobby Black's death when Jimmy McAfee got the egg on his? (41st?) birthday. Is Roscoe?Jame's father??I estimate this birthday at 1927, though it could be anywhere from 1922-1932. For the Christmas Blaine remembers to be before prohibition, it would have been the Christmas of 1919, but Jimmy McAfee should have already been almost 30 years old. Why the generational slippage in Blaine's memories? If the egg is related to the Simurgh, which according to some legends has Phoenix like properties, the parent and the child are the "same". 

An additional time slippage occurs when Aunt Della stays at the "haunted" hotel and is transposed with the future: she looks out to the lights of autos and the modern visitor is astonished at lights (candles) in the room when she calls. 

Weer's age is 50 when he receives the letter from the dog boy, and a 50 year old woman shows up to show concern for Doris. This is too old to be Sherry but is just the right age to be Margeret Lorn (Mrs. Price). Time slippage with the carnival or is Doris, rather than Sherry Gold's, something to do with Margeret Lorn, Den's childhood love? We do know that "Mr. Mason", the supposed father, is thought to be fictional by the dog-boy Charles Turner. It seems unlikely that Den could have an affair with Margeret Lorn when she was 35 years old, but this is the age of Lois Arbuthnot the librarian when he is about 45. 

Is Blaine just forgetful or is there a particular reason he latches onto Weer as "Jimmy" - the eventual owner of the egg?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20131221/5f2a4154/attachment.htm>

---

From: Marc Aramini <marcaramini at yahoo.com>
Date: Sat, 21 Dec 2013 23:48:26 +0000

Well, Roscoe is not the name of James Mcafee's father - according to Weer early in the book it was Donald Mcafee.  (Who is Roscoe, then, and why has Blaine taken to calling James Roscoe and Alden Jimmy?)

Sent from my iPhone