Subject: (urth) (no subject)

From: michael.o.thayer at gmail.com <michael.o.thayer at gmail.com>
Date: Tue, 26 Jun 2018 06:08:37 +0000

https://goo.gl/9U1N67

---

From: Ab de Vos <foxyab at casema.nl>
Date: Tue, 26 Jun 2018 09:57:59 +0000

Bitdefender blocked your page because of phishing.

Op 26-6-2018 om 08:08 schreef michael.o.thayer at gmail.com:
>    Hello Urth
>
>
>
> https://goo.gl/9U1N67
> _______________________________________________
> Urth Mailing List
> To post, write urth at urth.net
> Subscription/information: http://www.urth.net