Subject: (urth) (no subject)

From: michael.o.thayer at gmail.com <michael.o.thayer at gmail.com>
Date: Sun, 10 May 2020 04:56:02 +0000

Urth
??
https://chogoon.com/srt/1tyr5
??
??
??

??
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20200510/4087843a/attachment.html>

---

From: Gerry Quinn <gerry at bindweed.com>
Date: Mon, 11 May 2020 12:15:16 +0000

I just get 'Forbidden' when I click on the link.

- Gerry Quinn

On 10/05/2020 05:56, michael.o.thayer at gmail.com wrote:
> _______________________________________________
> Urth Mailing List
> To post, write urth at urth.net
> Subscription/information: http://www.urth.net

-- 
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20200511/f560f411/attachment.html>