Subject: (urth) (no subject)

From: michael.o.thayer at gmail.com <michael.o.thayer at gmail.com>
Date: Sun, 21 Jun 2020 22:06:41 +0000

Urth
??
??
https://bit.ly/2YhjDc6
??
??
??
??
??
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20200621/b3099906/attachment.html>

---

From: Gerry Quinn <gerry at bindweed.com>
Date: Mon, 22 Jun 2020 04:31:58 +0000

On 21/06/20

> https://bit.ly/2YhjDc6
Not sure Gene is ever going to be the poster-child for fat reduction 
regimes...

- Gerry Quinn

-- 
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.urth.net/pipermail/urth-urth.net/attachments/20200622/d3ef1860/attachment.html>