Subject: (whorl) TALUS - an acronym?

From: Latro1 <latro1 at aol.com>
Date: Mon, 01 Jun 1998 22:02:20 +0000

Hi, I'm new to the Whorl list and I've got a question:
What if TALUS is an acronym?

Titanium Armored Large Undercarriage Soldier
Tank Artillery Logistical Underground Soldier
Totally Angry Large Ugly Soldier

*More Wolfe info & archive of this list at http://www.moonmilk.com/whorl/

---

From: Michael Straight <straight at email.unc.edu>
Date: Mon, 01 Jun 1998 21:10:54 +0000

> Totally Angry Large Ugly Soldier

Well, Horn doesn't write it in all caps, so if it originally was an
acronym, it's probably one like 'radar' or 'scuba' where most people don't
know what it stands for or even that it ever was an acronym.

So I'd put that under 'possible, but I doubt we'll ever get any evidence
for it.'

-Rostrum